Get in touch
Back
Resolved

We're currently dealing with some issues, we'll be back shortly.

Started 23 Feb at 10:20pm GMT.

Created

Our currency conversion isn't working as intended, please bear with us while we look into this. We're aiming to be back online within 30 minutes (2300 UTC).

Update: Sorry folks, it's taking a bit longer than expected to resolve our errors, we're working hard to get back online asap.

Posted 23 Feb at 10:20pm GMT.